Creality 4.2.7 silent board and BLTouch upgrade for Ender 3 Pro

I wanted the silent board to reduce noise since our printer is near the TV. The BLTouch I wanted for my partner so they wouldn’t have to worry about bed leveling when they tried to print.

After doing some research, I devised the following high-level overview of a plan to get this working.

  1. Trade out the existing 4.2.2 board for the 4.2.7 silent board.
    1. Take pictures of wiring so I don’t screw up where everything goes before dismantling.
  2.  Do a quick power on a and check basic functionality.
    1. Verify everything is getting power
    2. All components are communicating
    3. There are no errors.
  3. Install BLTouch
    1. Upgrade the firmware of the 4.2.7 board to include BLTouch support.
    2. Install BLTouch and do a temporary wire run just to verify functionality.
    3. Verify auto home and bed leveling are good.
    4. Print CHEP cube, adjust if necessary.
    5. Go back and fix the BLTouch wiring and put it in the mesh sleeve.

Things I didn’t plan for:

  • Hot glue over all the connectors where the cables meet the board. This took forever picking the glue off as it never came off in one chunk and would be in between crevasses.
  • Creality is not clearly being descriptive about what firmware is for what. They seem to have many download locations, one of which is outdated, another had some files but not the one I needed and none give more details than what the file is called.
  • BLTouch needs much more adjusting than the provided instructions say. I knew adjustments would but needed, but it was more even than the videos I watched showed and this was my fault in the end which I will explain later.

So here is how the 7-hour upgrade went from start to finish.

I opened the board enclosure and took a few pictures from different angles of all the connectors and sockets. Most are labeled but some are not like the hot bed and nozzle thermistor which look identical and are impossible to trace back without removing from the protective sleeving. So these were the only two I really needed to worry about. The hot end had two same-colored red power cables. I assume their ports didn’t matter but didn’t want to risk it and was careful with these also.

The first issue I ran into was the hot glue over all the connectors. I knew there might be glue due to videos I researched beforehand but this glue was tacky and didn’t come off cleanly. It would come off in small chunks and I probably wasn’t using the best tools for it. The printer also had just finished a print and was warm so that probably didn’t help. I saw at one point the board connectors coming off the soldered posts when pulling, so you really need to clear the glue from the crevasses first and not try and brute force it. This took hours to do right, you need to take your time not to break anything so plan for it.

Switching over the wiring and installing the board went without any issue. It was direct plug-and-play. Turning on the printer with the new 4.2.7 board went fine and basic checks passed though did have a very old firmware on it.

Now the fun started. I first picked the wrong firmware to flash. I had gone to the Creality Creative Cloud download section under support which turned out not to be the location I will eventually get the firmware from. I spent probably 2 hours or so figuring this out between the LCD screen buzzing at me trying different firmware options from the bundle I downloaded as well as researching.

Flashing these incorrect firmware options resulted in the buzzer on the LCD display constantly making noise. I later found out that the BLTouch socket in an older firmware pin was used for a buzzer and was repurposed for BLTouch later on when it combined the axis into one connector instead of two. Marlin version was also 1.3.1 of this firmware. So why was the firmware called Marlin2.0.1? I have no clue and blame Creality for poor documentation on the matter.

This then lead me down the rabbit hole of custom building and compiling Marlin with BLTouch for the 4.2.7 board myself which I had too many questions about and wanted my printer up sooner than it would take me to properly understand all this. But did spend a solid 2 hours researching and attempting. I do want to try this again in the future when I have more time to learn it.

I did some more research on Crealitys firmware and was directed to their old download location which was a google drive share and had not been updated in a few years. I then when back to the main Creality website and clicked the Download Center link under Support ->Software & Firmware below the Download in Creality Cloud that I clicked earlier. This then had me select my printer and was presented with many download links one of which was called “Ender-3 Marlin2.0.6HW4.2.7 BLTouch Filament”. I looked for one without the filament sensor as I didn’t have one but that was all that came close to my requirements. Maybe I could disable the filament sensor? Only one way to find out, so I download and flashed it. The flash seemed to fail and I was left with a blue screen on the LCD that never exits. After much troubleshooting, I formatted the SD card and put the new firmware I found back on, it then flashed fine. My guess is the card got corrupted at some point.

Oh man, the LCD isn’t buzzing at me, the Marlin version says 2.0.6, not an ancient version, and BLTouch menus are present. The filament sensor, sure enough, had an ON/OFF toggle which I set to off since I don’t have one. This is great! I then would spend a few hours more researching and configuring hot end and bed temp and the X Y Z axis points. When I had formatted my SD card I stupidly blew away my config file that I later found the Creality compiled version of marlin uses for saving settings instead of writing to the firmware. I learned about this as well as setting up the BLTouch in this video which was a fantastic find and chocked full of great information. BV3D: Bryan Vines – Level Up! Install Creality’s BLTouch Bed Leveling Kit on Ender-3 V2! I probably would have only had to do the Z-axis work if I didn’t blow away that file. These are some of the reasons why I want to attempt to compile my own version of Marlin at some point.

This all could have been made a bit better if Creality had some better documentation on process and downloads. They provide the hardware for exactly these types of upgrades. Brands such as Prusa though significantly more expensive are much better with their support and documentation. I learned a ton of great information going through all this and due to that, it was worthwhile.